How to sync Google Assistant with Geeni app?

Follow

Comments

41 comments

  • Avatar
    Tyler Coviello

    Unable to connect to Google home app. Keep getting error: "Couldn't update the setting. Check your connection."

    4
    Comment actions Permalink
  • Avatar
    Edwin Culberson

    Same here

    4
    Comment actions Permalink
  • Avatar
    Tyler Coviello

    Attempted to delete both greeni app & Google home app. Removed Google home mini from my Google home account. Switched wifi on and off. Maybe it's an issue with the API?

    0
    Comment actions Permalink
  • Avatar
    Michael Paul

    Same here. The lights connected to my wi-fi quickly and easily. The app controls the lights individually and in a group perfectly. Unfortunately, when I try to link it to my Google Home, I get the same error, "couldn't update the setting. Check your connection." Hopefully this is fixed soon.

     

    Something interesting: When I copy and paste the authorization link from my phone into my laptop browser and enter my Geeni credentials, it says something to the effect of "accounts have been linked", but then it tries to open the Home app and fails of course because it's on my laptop. With hope and optimism, I get back into my Google Home app on my phone only to find out that nothing has been linked and my Geeni account isn't connected. Maybe this can help move the troubleshooting process forward a bit.

    3
    Comment actions Permalink
  • Avatar
    Michael Paul

    I just tried linking my Geeni account to my Google account. It sat for a long time after entering my credentials, which gave me hope, but in the end, it failed. I tried a second time, AND IT CONNECTED! My devices are finally added to my Google Home app. I'm cautiously going to say that the issue is fixed.

    0
    Comment actions Permalink
  • Avatar
    Tyler Coviello

    I just attempted to connect them again and IT WORKED. If anyone at geeni got on the side thank you. Or maybe at Google. I sent feedback to them through the Google home app. Voice controls also working nicely too.

    1
    Comment actions Permalink
  • Avatar
    David Morgan

    I'm able to set up the Merkury smart bulbs on the Geeni app, but I cannot link them to Google Assistant.

    When I enter my Geeni credentials into Google Assistant to link the account, I get a 401 error ("Your client does not have permission to the requested URL /services/auth/handoffs/auth/complete?state=[blah blah encrypted string here]

    0
    Comment actions Permalink
  • Avatar
    Jason W

    I keep trying to link Geeni to Google home but it keeps saying incorrect username or password. I have verified and tried over and over again but it will not connect. 

    1
    Comment actions Permalink
  • Avatar
    xcruzz

    I don't even see the option to add control on my Google home app. It's been a while since this is not working and it's disappointing they were able to advertise, but not to check that it works

    0
    Comment actions Permalink
  • Avatar
    Christina Piecara

    I keep getting invalid username & password. Even went into Geeni app & changed password & it still won't work.

    1
    Comment actions Permalink
  • Avatar
    David Derouin

    FOLKS-

    If you are experiencing an issue signing in to LINK Geeni to Google Home, I stumbled upon the answer in my case:

    make sure you use GOOGLE CHROME as your sign in browser

    I was using Internet Explorer on android and would receive "account now linked" text with nothing happening until I switched my browser on a hunch that google driven operation would be more issue free using their applications.

     

    I hope this helps, and if so, GEENI posts this in their official instructions.

     

     

    1
    Comment actions Permalink
  • Avatar
    Tracey Gold

    David Derouin

    I have been fighting with the Google Home connection for an hour. I could use the light options fine with the app but no voice control Google Home kept saying it was unavailable. I read your solution and switched my browser from Samsung Internet to Google Chrome and the light started working instantly with voice commands! Good stuff Thank you!

    1
    Comment actions Permalink
  • Avatar
    Phillip Williams

    Sad to find I just bought some of these devices and it just will not connect to Google Home. Just keeps endlessly telling me my login is wrong. It is not.

    1
    Comment actions Permalink
  • Avatar
    David Slingerland

    Same issue with the "incorrect username/password" I can't figure it out. I know my username and password are correct...

    1
    Comment actions Permalink
  • Avatar
    Tracey Gold

    I have two sign ins one on the app that uses my mobile# and password and the one to sign in here that uses my email and a password. The mobile # and password is what you have to use to sign in through google home.

    1
    Comment actions Permalink
  • Avatar
    Corey Campbell

    Getting username and password incorrect as well. I know I am putting the right info.

    3
    Comment actions Permalink
  • Avatar
    David Slingerland

    I initially had it set up with my phone number, but after that didn't work I switched to email. Both options gave me the same username/password incorrect error.

    3
    Comment actions Permalink
  • Avatar
    Relly Rell

    Has anyone found a Solutions incorrect password errors

    0
    Comment actions Permalink
  • Avatar
    Ronald Johnson

    I haven't, it finally stopped with the password errors and acted as if it was going to link the account, but it never shows up with the devices or that it's even linked. I'm not sure why it won't connect anymore. It was connected once before and randomly dropped. I did notice a network error a few times and its telling me my network is unstable even though EVERYTHING is working fine in my house on the net besides linking the two accounts....

    0
    Comment actions Permalink
  • Avatar
    Corey Campbell

    I'm getting the same thing too. I've gone from invalid login to saying it's linking but never shows as linked. I'm going to keep try but right now over 50% of home devices are useless with Google Home.

    Hey, Support! Any thoughts?

    0
    Comment actions Permalink
  • Avatar
    Jack Adrian Zappa

    Your all are getting further than I am. Can't even get Google Home to step 3. Apparently they have updated the Google Home app.  They have an Add button. I use Add > Setup new devices in your home > [Home] > Next. It then says it's Looking for devices and then says Multiple devices found.  However the devices are:

    1. Setup some smart lights
    2. Don't see your device

    I have a light and a plug, but going to Option 1 didn't work.

    Not sure what to do next. 😔

    0
    Comment actions Permalink
  • Avatar
    David Derouin

    USE GOOGLE CHROME AS YOUR BROWSER to have the linking go through. I contacted Geeni regarding this fix which worked for me and detailed this posted MAJOR issue

    2
    Comment actions Permalink
  • Avatar
    Jack Adrian Zappa

    Sorry David, I don't understand what you mean. There is no browser being brought up.  When would one be brought up at all?

    0
    Comment actions Permalink
  • Avatar
    Christina Piecara

    So after a lot of trial & error & customer service & tech support, I find the issue.
    1. You can only link your Geeni account with your Google Home if your Geeni account was set up online using your email address. NOT through the app using your phone number.
    2. What you have to do is delete your phone # account & create 1 with your email on the Geeni website.
    3. Login to the Geeni app with your email account.
    4. Then you will be able to link the 2 together. When prompted in Google, login with your email & password.
    **Yes, you will have to set all your devices up again.

    1
    Comment actions Permalink
  • Avatar
    William Marsh II

    This still does not work, i used an email on my first setup (geeni), i can log into that fine, But it will not link to the hub, just goes back to asking to sign in with geeni account in chrome

    0
    Comment actions Permalink
  • Avatar
    Larry Hinkle

    Hey Folks. After going thru the tedious task of getting it set up for Google Home. It doesnt respond to voice commands.  Have to manually open Home and click a button. So for me its literally pointless. No better than just using their app. 

    0
    Comment actions Permalink
  • Avatar
    Samantha S

    I finally figured out how to connect the Google Home to my Geeni bulbs, but as the commenter before me said, it seems that voice commands don't work to turn on the bulbs. Doesn't seem like there's much point to connecting them, but here's how I did it if anyone wants to know:

     

    Open the Google home app. Click Add, then Set up device. Under the heading "Works with Google," click "Have something already set up?" and scroll down until you see Geeni. You'll have to log in using your Geeni account, and then the two should be connected. Back in the Google Home app, you'll see your Geeni devices and you can assign them to bedrooms if you wish. 

    0
    Comment actions Permalink
  • Avatar
    Will Howson

    It worked when I switched browser. 

    0
    Comment actions Permalink
  • Avatar
    John Gillich

    Tried all of the above and google home still won’t recognize the doorbell camera.

    any ideas?

    0
    Comment actions Permalink
  • Avatar
    Tyler Coviello

    I had some issues with the wifi connected outlets. I logged into my routers settings, as it automatically managers the 2.4Ghz & 5 Ghz signal. Most home wifi products use 2.4 Ghz. I disabled the 5 Ghz connected the outlets to the network, then turned the 5 Ghz back on, and everything is currently working fine.

    0
    Comment actions Permalink

Please sign in to leave a comment.

Return to top