How to set up Geeni smart Wi-Fi camera?

Follow

Comments

41 comments

  • Avatar
    Jaeleen Breshears

    Alex,
    I'm not sure how to get into my router I have my internet through the utility company.

    0
    Comment actions Permalink
  • Avatar
    Alex Javier Gonzalez Rodriguez (Lamia)

    Jaeleen, find the ip number assigned to your camera trough the app and call your internet provider and tell them to put that ip address in the DMZ option of their router and once done, test the app with your camera.

    0
    Comment actions Permalink
  • Avatar
    Kimberly Evans

    I am having the same problem. Tried adding IP address to router manually and it asks for a MAC address. The only thing I see close to that is the device Id. I enter that and it says invalid MAC address. 

    0
    Comment actions Permalink
  • Avatar
    Ernestine Camp

    I am having the same problem with the constructing encryption channel message on new camera. Has anyone got theirs fiixed yet? 

     

    0
    Comment actions Permalink
  • Avatar
    Jaeleen Breshears

    No, I just called yesterday and they are still working on it. Still no set date for when it'll be done.

    0
    Comment actions Permalink
  • Avatar
    Armando Cabrera

    Looks like issue with “constructing encryption channel” issue got fixed with the latest app update. My cameras are working now and I have nothing to complain about.

    1
    Comment actions Permalink
  • Avatar
    Jaeleen Breshears

    I agree Armando my app is working perfectly fine as well. Nice being able to be at work and see whats going on at home.

    0
    Comment actions Permalink
  • Avatar
    Vince

    It was a pain in the butt, but I figured out the problem. I was only able to connect my cameras to the home WIFI by disabling the Wi-Fi MAC Filtering. Once I connected both of my cameras, I enabled the Wi-Fi MAC Filtering to my router settings. I hope this helps people having the same trouble.

    0
    Comment actions Permalink
  • Avatar
    Erica Preskitt

    I've tried connected my camera for the past hour. I just unboxed it so it's brand new. Does anyone know if there are issues going on with it? I've reset my phone, the app, the camera....I'm at a total loss.

    0
    Comment actions Permalink
  • Avatar
    Armando Cabrera

    Make sure your camera is connecting to the WiFi frequency 2.4Ghz

    0
    Comment actions Permalink
  • Avatar
    Christian Florit

    I just bought a Geeni Look 720p, and I am having such a HELL time trying to connect this stupid camera! The stupid guide is for an old version of the app, which doesn't have AP mode anymore... The camera also doesn't even attempt to read the QR Code!

    I bought 3 from Canadian tire online, but only received one atm, returning this $&#*$ right now!

    0
    Comment actions Permalink

Please sign in to leave a comment.

Return to top